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Introduction 
Adobe Illustrator is a useful tool for academics, but also rather handy for non-academic purposes as 
well. In this tutorial I will describe a way of tracing images in Adobe Illustrator to turn the original image 
into a simplified vector graphic (i.e., the file is saved as a series of formulas rather than an ordering of 
pixels). While I perform this approach on a photograph of a tea kettle, the same technique can be used 
on simple icon images, photographs of people or pets or scenery, or nearly any image.  

My research presentations for conferences and other venues all include a matching set of clipart using 
the approach below. My research posters often borrow clipart from these talks. My research 
publications also include conceptual and technical diagrams that use some of these methods. In short, 
drawing a tea kettle may be a silly task, but through the drawing of a simple object we can understand 
the methods for generating a drawing with a more professional purpose. 

Tutorial 
This tutorial was written using Adobe 
Illustrator CS5.1, although I have been 
following a nearly identical process 
using prior versions of Illustrator since 
2009, so it should withstand the test 
of time adequately. 

Window Setup 
Open Adobe Illustrator. Ensure you 
have the windows (on the left) 
viewable. 
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Copy and Paste Image into a New File 
Create a New File (File > New) and paste your desired image into the artboard. For this tutorial I 
performed a web search and decided upon a Le Creuset tea kettle. When tracing photographs of people, 
the image selection process can be rather tricky, but most object photographs are easily trace-able 
without considerable artistic skill. 

 

Figure 1. A screenshot of the Adobe Illustrator workspace, with important features described. 

Setup Layers 
In the Layers Window, lock the layer that contains the image so that it won’t move when you’re editing 
it. Then, create a new layer by clicking the appropriate button on the Layers Window. This will be the 
layer we draw our strokes onto. 
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Select Pen Tool 
We will be drawing with the pen tool, which can be selected through the Toolbar as shown below, or 
through the keyboard shortcut ‘p’. For this phase of drawing, we just want a line color (i.e., stroke) and 
not a filled-in shape (i.e., fill), so ensure that the fill color is transparent and you have a stroke color 
chosen, as shown in the image on the right: 

    

Trace Similarly-Colored Sections 
Looking at the photo of the tea kettle we can see several uniquely shaded parts of the image: the handle 
is a different color from the handle supports, the top of the knob is darker than the sides, the red lid is 
brighter than the red body, there are white reflective portions on the kettle, and silver metallic parts as 
well. Discerning these different coloring groups requires a bit of an artistic eye and it is in this step 
where things tend to go wrong. Try your best to trace these distinct groups with the pen tool, ensuring 
to close the object (there will be a little ‘o’ next to the pen cursor when you’re hovering over a point 
that will close the object, as shown in ‘Connect to Original Anchor by Click-and-Dragging It’). 

The pen tool can be difficult to master at first, which is why it has its own section in this tutorial entitled 
‘Using the Pen Tool’. Each time you click, be sure to click-and-hold and then drag the cursor. Little 
handles will appear denoting what angle and at what intensity the line will follow. When you place 
another point by clicking, repeat this process and you should eventually be able to notice a pattern 
between the angle and length of the bars and the line it produces. 
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Keep tracing distinct color shapes until everything is traced: 
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Fill in with Colors 
Now fill in the shapes with fill colors. This is done in the Color Window, by setting the stroke color to 
transparent and the fill color to the desired shade.  

 

For this kind of tracing, I often use the eye-dropper tool from the Toolbar (or ‘i’ keyboard shortcut) to 
pick up a color from the photograph itself, or to repeat a color I’ve previously used on another shape. 
This also allows me to easily make a nearly identical color that is just a bit darker (see the ‘K’ slider in the 
Color Window) than the previous one. 
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Toggle Visibility of Layers 
Sometimes the newly filled shapes block your view from seeing the colors they should be. Or when you 
finish your drawing, you may not want the original photograph to be visible. To do this, you can toggle 
the visibility of the layer on the Layer Window. 

 

Set Transparency 
Some of the objects of your drawing may require partial transparency to get the desired effect. On the 
tea kettle, there are a few reflective areas that require this treatment. Simply fill in the transparent 
areas with white (or whichever color desired), select the object, and modify its opacity in the 
Transparency Window. 
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Occasionally, depending on the order in which you have drawn all your shapes, one shape may be 
blocking another shape because it is on top of it. If this is the case, you will need to select the object you 
wish to bring backward or forward, and go to Object > Arrange > Bring to Front 
(keyboard shortcut: Ctrl + Shift + ]). This is shown in the Arrangement subsection of Tips and Tricks. 

Done! 
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Tips and Tricks 
The previous tutorial gives a brief overview with the basic steps for tracing an image in Adobe Illustrator. 
However, sometimes things do not go quite as planned and you need to arrange, align, or otherwise 
move something that has already been drawn.  

Moving Objects and Single Points 
To move an entire object in Adobe Illustrator, you can use the Selection Tool (keyboard shortcut: V) 
from the Toolbar. You can rotate an entire object using the Selection Tool. To modify a pen point, 
including its angles/handles, use the Direct Selection Tool (keyboard shortcut: A).  

 

Grouping 
When you have a group of objects that belong together and you wish to move them collectively without 
having to constantly select every point each time, then Grouping is the solution. Select all the points you 
consider in your group (using the Selection or Direct Select Tools). Then go to Object > Group 
(keyboard: Ctrl+G). In this way, an object can be a single shape or several grouped shapes. 
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Arrangement 
Your multiple drawn objects work as layers, like plates piled on top of each other. Only the top plate is 
fully visible, if the others are arranged underneath this. Sometimes, you need to bring one of the lower 
layers upwards to be more visible and cover parts of one of the other layers. Select the object you wish 
to bring backward or forward, and go to Object > Arrange > Bring to Front (keyboard 
shortcut: Ctrl + Shift + ]). 

 

Figure 2. Notice how the spout of the red tea kettle above is blocked by the blue tea kettle. By bringing the red tea kettle 
forward, the spout becomes visible (on the bottom). 
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Flipping Vertically or Horizontally 
Flipping an object in Adobe Illustrator is called ‘Reflect’. Select the object you would like to reflect, and 
then go to Object > Transform > Reflect and select either horizontally or vertically. 

 

Alignment 
Objects can be aligned to be centered vertically or horizontally, or to align left or right using the Align 
Window. Select your objects, and then select the button representing the desired alignment. 
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Distribute Space 
Adobe Illustrator can be used to distribute the space between objects evenly, either along horizontal 
space or vertical space. This is done at the bottom of the Align Window as shown in the screenshot 
below: 

 

Rotate 
Aside from using the Selection Tool to drag-and-rotate an object (also: try holding shift as you do so to 
rotate 45 degrees at a time), you can also use the Transform > Rotate menu. Be sure to select 
your desired object first. 
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Using the Pen Tool 
The pen tool can be a bit tricky to get a handle of. These steps introduce a few ways of managing. 

Select Pen Tool and Click-and Drag. 
Select the Pen Tool (P keyboard shortcut), click-and-drag. When you click a new point or anchor is made. 
As you drag, handles that determine the angle of the line coming into and out of that anchor appear. 
The longer the handles, the greater the strength of the angle. 

 

Click-and-Drag to Create a Second Anchor 
Click-and-drag to create a second anchor. This anchor should automatically connect to the previous one. 
However, if it does not simply click-and-drag on the previous anchor. This is a good stage to start playing 
with the handle length and seeing how it affects the starting and ending angles of the line that connects 
the two anchors. 
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Clicking Without Dragging Creates a Corner Point (i.e., No Handles) 
If you click and don’t drag at all, then the anchor created will not have handles and will essentially turn 
out to be a slightly pointed corner, depending on the angles of the anchors that come before and after 
it. 
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Keep Click-and-Dragging Anchors Until You Reach the Original Anchor 

 

Connect to Original Anchor by Click-and-Dragging It 
When you connect to the original anchor point, the pen cursor will have a little circle appear next to it. 
Click-and-dragging will allow you to modify the handle of the line going into the original anchor point 
and this will close the shape. 
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Moving Existing Anchor Points 
To move an existing anchor point, select the Direct Selection Tool (‘A’ keyboard shortcut), then select 
the point to move, and move it.  

 

Add Points to an Existing Shape 
You can also add points to an existing shape. Select the ‘Add Anchor Point Tool’ (either click-and-hold 
the Pen Tool on the Toolbar or use ‘+’ keyboard shortcut). Place your cursor over the line you’d like to 
add an anchor to. Your pen cursor should have a plus-sign next to it. Click on the line and your new 
anchor will appear on the existing stroke. 

 



   
 How to Trace Images in Adobe Illustrator by Iris Howley  17 
 
 

In the previous example we added two points on either side of an existing point. We can now move the 
point in between them to get a more representative line, like so: 

 

We can also modify the strength of the angles on either side of this point by using the Direct Selection 
Tool to select a newly added point and then modify its handle length: 
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Continue Adding and Modifying Anchors to Create Several Shapes that Capture 
the Essence of the Original Image 

 


	Introduction
	Tutorial
	Window Setup
	Copy and Paste Image into a New File
	Setup Layers
	Select Pen Tool
	Trace Similarly-Colored Sections
	Fill in with Colors
	Toggle Visibility of Layers
	Set Transparency
	Done!

	Tips and Tricks
	Moving Objects and Single Points
	Grouping
	Arrangement
	Flipping Vertically or Horizontally
	Alignment
	Distribute Space
	Rotate

	Using the Pen Tool
	Select Pen Tool and Click-and Drag.
	Click-and-Drag to Create a Second Anchor
	Clicking Without Dragging Creates a Corner Point (i.e., No Handles)
	Keep Click-and-Dragging Anchors Until You Reach the Original Anchor
	Connect to Original Anchor by Click-and-Dragging It
	Moving Existing Anchor Points
	Add Points to an Existing Shape
	Continue Adding and Modifying Anchors to Create Several Shapes that Capture the Essence of the Original Image


